You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
spacefrogg-overlay/pharo.nix

14 lines
372 B

{ stdenv, makeWrapper, libgit2, libgit2_32, pharo }:
stdenv.mkDerivation {
name = "pharo";
buildInputs = [ makeWrapper pharo ];
phases = "installPhase fixupPhase";
installPhase = ''
mkdir -p $out/bin
ln -s ${pharo}/bin/pharo $out/bin
wrapProgram $out/bin/pharo --prefix LD_LIBRARY_PATH : ${stdenv.lib.makeLibraryPath [ libgit2 libgit2_32 ]}
'';
}